Upgrade Issues

Problem Summary

Some customers may not have run the os_upgrade module to upgrade the CentOS 7 appliances during a CloudCenter upgrade to 4.10.0.7. Attempting to run the core_upgrade.bin os_upgrade module after CloudCenter has been upgraded to 4.10.0.7 or later will result in the following error.

Error: 
We are at 4.10.0.7 or later.Skipping os_upgrade

Workaround

These customers may want to update the CentOS 7 appliances, and will need to manually run the update.

Verify the Docker and Java version before updating the OS packages.

docker version
java -version

Run YUM to ensure there are not errors.

yum --disablerepo='*' --enablerepo=base,extras,epel,updates  -y --exclude=java-1.8.0-openjdk,docker,docker-client,docker-common,java-1.8.0-openjdk-headless update --setopt tsflags=test

Update the OS

      yum --disablerepo='*' --enablerepo=base,extras,epel,updates --exclude=java-1.8.0-openjdk,docker,docker-client,docker-common,java-1.8.0-openjdk-headless -y update

Verify the Docker and Java version after update to make sure they did not change.

docker version
java -version


  • No labels
Terms & Conditions Privacy Statement Cookies Trademarks